AristotleK12 Status Page - AristotleK12 Login Issues – Incident details

All systems operational

AristotleK12 Login Issues

Resolved
Partial outage 50 %
Started 5 days agoLasted 32 minutes

Affected

AristotleK12

Partial outage from 2:26 PM to 2:58 PM

AristotleK12 Educator

Partial outage from 2:26 PM to 2:58 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are investigating the AristotleK12 Login issues. We are working hard to restore service. Thank you for your patience.