AristotleK12 Status Page - AristotleK12 Outage – Incident details

All systems operational

AristotleK12 Outage

Resolved
Partial outage
Started 9 days agoLasted 36 minutes

Affected

AristotleK12

Partial outage from 11:48 AM to 12:23 PM

AristotleK12 Educator

Partial outage from 11:48 AM to 12:23 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified

    We are on the case! AristotleK12 is experiencing some problems; we understand how frustrating that can be. Rest assured, we are working hard to fix it and will have things back up and running quickly. Thanks for hanging in there with us!